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1 Introduction

What Is the Communications Blockset?
The Communications Blockset extends Simulink® with a comprehensive
library of blocks to design and simulate the physical layer of communication
systems and components. The blockset helps you design communications
systems and their semiconductor components, such as commercial or defense
wireless and wireline systems.

The key features of the blockset are

• Blocks for designing and simulating the physical layer of communications
systems, including modulation, source and channel encoding, channels,
and equalization

• The ability to tune models and visualize the results

• Hierarchical, block-based models for visually conveying complex designs

• Integration with the Communications Toolbox for postsimulation analysis
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Installing the Communications Blockset

Installing the Communications Blockset
To build and run the models in this manual, you must first install the
Communications Blockset and the products it requires, which are listed below:

• MATLAB®

• Simulink

• Signal Processing Toolbox

• Communications Toolbox

• Signal Processing Blockset

You can find instructions for installing these products in the MATLAB
installation documentation for your platform. To determine what products
are installed on your system, enter ver in the MATLAB Command Window.
This displays information about the version of MATLAB you are running,
including a list of all toolboxes and blocksets installed on your system.
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Building Models

This chapter introduces you to Simulink and the Communications Blockset.
The chapter begins by showing you how to run an existing Simulink model
and how to build a simple model. It then explains how to build typical models
of communication systems using the Communications Blockset. These models
show you how to use the blockset and illustrate some of its important features.

Running a Simulink Model (p. 2-3) Running a demo model that is
included in the Communications
Blockset.

Building a Simple Model (p. 2-12) Building a Simulink model and
using Simulink block libraries. The
section also explains sample times,
frames, and sample-based versus
frame-based processing.

Building a Channel Noise Model
(p. 2-24)

Simulating a channel with noise and
calculating the system’s bit error
rate.

Reducing the Error Rate Using a
Hamming Code (p. 2-30)

Introducing an error-correcting code
and viewing errors in a scope.

Modeling a Channel with Modulation
(p. 2-39)

Modeling binary phase shift keying
(BPSK) modulation and additive
white Gaussian noise (AWGN).

Reducing the Error Rate with a
Cyclic Code (p. 2-42)

Using a binary cyclic code. The
section also shows how to determine
frame sizes and frame periods of
signals.



2 Building Models

Building a Frequency-Shift Keying
Model (p. 2-47)

Modeling frequency-shift keying and
compensating for delays created by
blocks in the model.

Building a Convolutional Code
Model (p. 2-54)

Using a convolutional code.
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Running a Simulink Model

Running a Simulink Model
This section describes a demo model of a communications system that comes
with the Communications Blockset. The model displays a scatter plot of a
signal with added noise. The purpose of this section is to familiarize you with
the basics of Simulink models and how they function.

The section takes you through some key elements of working with this model,
including these topics:

• “Opening the Model” on page 2-3

• “Overview of the Model” on page 2-4

• “Quadrature Amplitude Modulation” on page 2-5

• “Running a Simulation” on page 2-6

• “Displaying the Error Rate” on page 2-7

• “Setting Block Parameters” on page 2-8

• “Displaying a Plot of Phase Noise” on page 2-9

• “More Demos” on page 2-10

Opening the Model
To open the model, first start MATLAB. In the MATLAB Command Window,
enter phasenoise_sim at the prompt. This opens the model in a new window,
as shown in the following figure.
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2 Building Models

Overview of the Model
The Simulink model shown in the preceding section, “Opening the Model”
on page 2-3, simulates the effect of phase noise on quadrature amplitude
modulation (QAM) of a signal. The Simulink model is a graphical
representation of a mathematical model of a communication system that
generates a random signal, modulates it using QAM, and adds noise to
simulate a channel. The model also contains components for displaying the
symbol error rate and a scatter plot of the modulated signal.

The blocks and lines in the Simulink model describe mathematical
relationships among signals and states:

• The Random Integer Generator block, labeled Random Integer, generates a
signal consisting of a sequence of random integers between zero and 255

• The Rectangular QAM Modulator Baseband block, to the right of the
Random Integer Generator block, modulates the signal using baseband
256-ary QAM.

• The AWGN Channel block models a noisy channel by adding white
Gaussian noise to the modulated signal.
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Running a Simulink Model

• The Phase Noise block introduces noise in the angle of its complex input
signal.

• The Rectangular QAM Demodulator Baseband block, to the right of the
Phase Noise block, demodulates the signal.

In addition, the following blocks in the model help you interpret the
simulation:

• The Discrete-Time Scatter Plot Scope block, labeled AWGN plus Phase
Noise, displays a scatter plot of the signal with added noise.

• The Error Rate Calculation block counts symbols that differ between the
received signal and the transmitted signal.

• The Display block, at the far right of the model window, displays the
symbol error rate (SER), the total number of errors, and the total number
of symbols processed during the simulation.

All these blocks are included in the Communications Blockset and Simulink.
You can find more detailed information about these blocks by right-clicking
the block and selecting Help from the context menu.

Quadrature Amplitude Modulation
This model simulates quadrature amplitude modulation (QAM), which is
a method for converting a digital signal to a complex signal. The model
modulates the signal onto a sequence of complex numbers that lie on a lattice
of points in the complex plane, called the constellation of the signal. The
constellation for baseband 256-ary QAM is shown in the following figure.
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2 Building Models

Constellation for 256-ary QAM

Running a Simulation
To run a simulation, select Simulation > Start from the top of the model
window. The simulation stops automatically at the Stop time, which is
specified in the Configuration Parameters dialog box. You can stop the
simulation at any time by selecting Stop from the Simulation menu at the
top of the model window (or, on Microsoft Windows, by clicking the Stop
button on the toolbar).

When you run the model, a new window appears, displaying a scatter plot of
the modulated signal with added noise, as shown in the following figure.
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Running a Simulink Model

Scatter Plot of Signal Plus Noise

The points in the scatter plot do not lie exactly on the constellation shown in
the figure Constellation for 256-ary QAM on page 2-6 because of the added
noise. The radial pattern of points is due to the addition of phase noise, which
alters the angle of the complex modulated signal.

Displaying the Error Rate
The Display block displays the number of errors introduced by the channel
noise. When you run the simulation, three small boxes appear in the block,
as shown in the following figure, displaying the vector output from the Error
Rate Calculation block.

Error Rate Display

2-7



2 Building Models

The block displays the output as follows:

• The first entry is the symbol error rate (SER).

• The second entry is the total number of errors.

• The third entry is the total number of comparisons made. The notation
1e+004 is shorthand for 104.

Setting Block Parameters
You can control the way a Simulink block functions by setting its parameters.
To view or change a block’s parameters, double-click the block. This opens a
dialog box, sometimes called the block’s mask. For example, the dialog box for
the Phase Noise block is shown in the following figure.

Dialog for the Phase Noise Block

To change the amount of phase noise, click in the Phase noise level
(dBc/Hz) field and enter a new value. Then click OK.

Alternatively, you can enter a variable name, such as phasenoise, in the
field. You can then set a value for that variable in the MATLAB Command
Window, for example by entering phasenoise = 2. Setting parameters in the
Command Window is convenient if you need to run multiple simulations with
different parameter values. See the section “Running Multiple Simulations”
on page 3-8.
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Running a Simulink Model

You can also change the amount of noise in the AWGN Channel block.
Double-click the block to open its dialog box, and change the value in
the Es/No parameter field. This changes the signal to noise ratio, in dB.
Decreasing the value of Es/No increases the noise level.

You can experiment with the model by changing these or other parameters
and then running a simulation. For example,

• Change Phase noise level (dBc/Hz) to -150 in the dialog box for the
Phase Noise block.

• Change Es/No to 100 in the dialog for the AWGN Channel block.

This removes nearly all noise from the model. When you now run a
simulation, the scatter plot appears as in the figure Constellation for 256-ary
QAM on page 2-6.

Displaying a Plot of Phase Noise
Double-click the block labeled “Display Figure” at the bottom left of the model
window. This displays a plot showing the results of multiple simulations.
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2 Building Models

Plot of BER at Different Noise Levels

Each curve is a plot of bit error rate as a function of signal to noise ratio for a
fixed amount of phase noise.

You can create plots like this by running multiple simulations with different
values for the Phase noise level (dBc/Hz) and Es/No parameters. “Running
Multiple Simulations” on page 3-8 describes how to do this with a MATLAB
script, using variables for the parameters.

More Demos
You can find more demos for the Communications Blockset by typing demo at
the MATLAB prompt or selecting the Demos tab in the Help browser. Click
the + sign next to Blocksets in the left pane, and then click the + sign next to
Communications. This displays categories containing the Communications
Blockset demos. To see a list of the demos in a category, click the + sign next to
the category name. Then double-click the name of a demo to open that demo.
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Building a Simple Model
In the previous section, you ran a model that was already built. This section
explains how to build a simple Simulink model that displays a sine wave in a
scope. For more detailed information on building models, see the Simulink
documentation.

The Basic Steps
This section describes the basic steps in building a model. It explains how to

• Set simulation parameters with commstartup

• Open a new model window

• Open block libraries

• Move blocks into a model window

• Connect the blocks

• Set block parameters

• Set simulation parameters

• Run the model

Building a model usually involves several iterations, as you decide which
blocks to include and what parameter settings to make. In the example in
this section, you refine the model by adding noise. The section explains how to

• Add noise to the model

• Save the model

The section also explains

• Frames and frame-based processing

• Discrete signals and sample times

• Continuous signals
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Building a Simple Model

Using commstartup to Set Simulation Parameters
Before starting to build the model, enter

commstartup

at the MATLAB prompt.

This

• Sets the Simulink Boolean logic signals parameter to Off

• Sets default simulation parameters that are optimal for communications
models

The Communications Blockset does not support signals with Boolean
data types. If you want to use Simulink blocks that output Boolean data
types, such as the Logical Operator block, in a model with blocks from the
Communications Blockset, enter commstartup before building the model. The
commstartup settings apply to any models you create during the current
MATLAB session. You must enter commstartup at the beginning of each
MATLAB session to establish these settings.

If you build a model without entering commstartup and subsequently decide
to use Simulink blocks that output signals with Boolean data types, turn off
the model’s Boolean logic signals parameter by entering

set_param('my_model', 'BooleanDataType', 'off')

where my_model.mdl is the name of the model.

Opening a New Model Window
The first step in building a model is to open a new model window. To do so,
select File > New > Model, and then select Model. This opens an empty
model window, as shown in the following figure.
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2 Building Models

Opening Block Libraries
The next step is to select the blocks for the model. These blocks are contained
in libraries. To view the libraries for the products you have installed, type
simulink at the MATLAB prompt (or, on Microsoft Windows, click the
Simulink button on the MATLAB toolbar). If you are using Microsoft
Windows, the Simulink Library Browser appears, as shown below.

Simulink Library Browser
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Building a Simple Model

The left pane displays the installed products, each of which has its own library
of blocks. To open a library, click the + sign next to the name of the blockset in
the left pane. This displays the contents of the library in the right pane.

You can find the blocks you need to build models of communication systems in
the libraries of the Communications Blockset, the Signal Processing Blockset,
and Simulink.

Moving Blocks into the Model Window
The next step in building the model is to move blocks from the Simulink
Library Browser into the model window. To do so,

1 Click the + sign next to Signal Processing Blockset in the left pane of
the Library Browser. This displays a list of the Signal Processing Blockset
libraries.

2 Click Signal Processing Sources in the left pane. This displays a list of
the Signal Processing Sources library blocks in the right pane. If you do not
see the Sine Wave block, scroll down the list until it is visible.

3 Click the Sine Wave block and drag it into the model window.

4 Click Signal Processing Sinks in the left pane of the Library Browser.

5 Scroll down in the right pane of the Library Browser until you see the
Vector Scope block, and drag the block into the model window to the right
of the Sine Wave block.

Once a block is in the model window, you can move it to another position by
dragging the block with the mouse.
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2 Building Models

Dragging a Block into a Model Window

Connecting Blocks
The small arrowhead pointing outward from the right side of the Sine Wave
block is an output port for the data the block generates. The arrowhead
pointing inward on the Vector Scope block is an input port. To connect the two
blocks, click the output port of the Sine Wave block and drag the mouse toward
the input port of the Vector Scope block, as shown in the following figure.

When the pointer is on the input port of the Vector Scope block, release the
mouse button. You should see a solid arrow appear, as in the following figure.

If you do not see a solid arrowhead, you have not made a connection. In this
case, click the arrowhead again, drag it all the way to the Vector Scope’s input
port, and release the mouse button.
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Building a Simple Model

Setting Block Parameters
To set parameters for the Sine Wave block, double-click the block to open its
dialog box, as shown in the following figure. Change the following parameters
by clicking in the field next to the parameter, deleting the default setting, and
entering the new setting in its place:

1 Set Amplitude to 5.

2 Set Frequency to 30.

3 Set Samples per frame to 100.

4 Click OK.

Note You must set Samples per frame to a value larger than 1 to see an
image of the sine wave in the Scope block.

Dialog box for the Sine Wave Block
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Setting Simulation Parameters
In addition to individual block parameters, the model also has overall
simulation parameters. To view the current settings,

1 Select the Simulation menu at the top of the model window.

2 Select Configuration parameters to open the Configuration
Parameters dialog box, as shown in the following figure.

Configuration Parameters Dialog Box

If you typed commstartup before creating the model, the Stop time should be
set to inf. The Stop time determines the time at which the simulation ends.
Setting Stop time to inf causes the simulation to run indefinitely, until you
stop it by selecting Stop from the Simulation menu.

The Stop time is not the actual time it takes to run a simulation. The actual
run time for a simulation depends on factors such as the model’s complexity
and your computer’s clock speed.

The settings in the Configuration Parameters dialog box affect only the
parameters of the current model.
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Building a Simple Model

Note To conserve memory in a model, click Data Import/Export on the left,
and clear the boxes next to Time and Output under Save to workspace
on the right.

Running the Model
Run the model by selecting Simulation > Start. When you do so, a scope
window appears, displaying a sine wave, as shown in the following figure.

Sine Wave Displayed in a Scope

Note If you do not see the sine wave in the scope, make sure that the
Samples per frame parameter for the Sine Wave block is set to 100.

When you are finished observing the simulation, select Simulation > Stop.
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Adding Noise to the Model
You can add noise to the model using the AWGN Channel block, from the
Channels library of the Communications Blockset. The block adds white
Gaussian noise to the sine wave. Move the block from the Simulink Library
Browser into the model window, as described in “Moving Blocks into the
Model Window” on page 2-15. You can add the block to the model as follows:

1 Extend the line between the Sine Wave block and the Vector Scope block by
dragging the Vector Scope block to the right, to make room for the AWGN
Channel block.

2 Click the AWGN block and drag it onto the line. This automatically
connects the Sine Wave block and the Vector Scope block to the AWGN
Channel block.

Sine Wave Plus Noise

Double-click the AWGN Channel block to open its dialog box, as shown in the
following figure. Click the down arrow in the Mode field and select Signal
to noise ratio (SNR).
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Dialog for the AWGN Channel Block

Now when you run the model, the scope clearly shows the added noise.

Sine Wave with Noise Added
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When you are finished observing the simulation, stop the model by selecting
Simulation > Stop.

Saving a Model
To save your model for future use, select File > Save. The first time you save
the model, this displays the Save As dialog box. In the Save in field, select the
directory where you want to save the model. It is best to keep your work files
in a separate directory from the files shipped with the product. In the File
name field, enter a name for the model, such as sine.mdl, and click Save.

To load the model in a future MATLAB session, first change your working
directory to the one where you saved the file. You can do this by selecting the
directory in the Current Directory field on the MATLAB toolbar. Then enter
sine in the MATLAB Command Window.

Frames and Frame-Based Processing
A frame is a sequence of samples combined into a single vector. By setting
Samples per frame to 100 in the Sine Wave block, you set the frame size to
100, so that each frame contains 100 samples. This enables the Vector Scope
block to display enough data for a good picture of the sine wave.

Another important reason to set the frame size is that many Communications
Blockset blocks require their inputs to be vectors of specific sizes. If you
connect a source block, such as the Sine Wave block, to one of these blocks,
you can set the input size correctly by setting Samples per frame to the
required value. The model described in “Reducing the Error Rate Using a
Hamming Code” on page 2-30 shows how to do this.

In frame-based processing, all the samples in a frame are processed
simultaneously. In sample-based processing, on the other hand, samples are
processed one at a time. The advantage of frame-based processing is that it
can greatly increase the speed of a simulation. If you see double lines between
blocks, the model uses frame-based processing.

Discrete Signals and Sample Times
The Sine Wave block in the Signal Processing Blockset generates a discrete
signal. This means that it updates the signal at integer multiples of a fixed
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time interval, called the sample time. You can set the length of this time
interval in the Sample time parameter in the block’s dialog box. In the
example described in “Building a Simple Model” on page 2-12, the Sample
time has the default value of 1/1000. All the sources in the Communications
Blockset and the Signal Processing Blockset generate discrete signals
exclusively. These sources are primarily designed for modeling digital
communication systems.

To learn more about sample times, see “Building a Frequency-Shift Keying
Model” on page 2-47.

Continuous Signals
The Simulink libraries also contain blocks that generate continuous signals.
This means that they update the signal at variable time intervals, whose
length is determined by the numerical solver the simulation uses. For
example, the Sine Wave block in the Simulink Sources library can generate a
continuous sine wave.

Note Many blocks in the Communications Blockset accept only discrete
signals. To find out whether a block accepts continuous signals, consult the
reference page for the block.
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Building a Channel Noise Model
This section shows how to build a simple model of a communication system.
The model, shown in the following figure, contains the most basic elements of
a communication system: a source for the signal, a channel with noise, and
means of detecting errors caused by noise.

Channel Noise Model

You are encouraged to build the model for yourself, as this is the best way to
learn how to use the Communications Blockset.

The topics in this section are as follows:

• “Overview of the Model” on page 2-24

• “Selecting Blocks for the Channel Noise Model” on page 2-25

• “Setting Parameters in the Channel Noise Model” on page 2-26

• “Connecting the Blocks” on page 2-27

• “Running the Channel Noise Model” on page 2-28

Overview of the Model
The channel noise model generates a random binary signal, and then switches
the symbols 0 and 1 in the signal, according to a specified error probability, to
simulate a channel with noise. The model then calculates the error rate and
displays the result. The model contains the following components.

Source
The source for the signal in this model is the Bernoulli Binary Generator
block, which generates a random binary sequence.
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Channel
The Binary Symmetric Channel block simulates a channel with noise. The
block introduces random errors to the signal by changing a 0 to a 1 or the
reverse, with a probability specified by the Error probability parameter
in the block’s dialog.

Error Rate Calculation
The Error Rate Calculation block calculates the error rate of the channel. The
block has two input ports, labeled Tx, for the transmitted signal, and Rx, for
the received signal. The block compares the two signals and checks for errors.
The output of the block is a vector with three entries:

• Bit error rate, which you expect to be approximately .01, because this is the
probability of error in the channel

• Number of errors

• Total number of bits that are transmitted

Display
The Display block displays the output of the Error Rate Calculation block, as
described in “Displaying the Error Rate” on page 2-7.

Selecting Blocks for the Channel Noise Model
To build the model, first move its blocks into a new model window, as follows:

1 Type commstartup at the MATLAB prompt to set simulation parameters
for the model.

2 Type simulink at the MATLAB prompt to open the Simulink Library
Browser.

3 From the menu, select File > New > Model to open a new model window.

4 Drag the following blocks from the Simulink Library Browser into the
model window:

• Bernoulli Binary Generator block, from the Random Data Sources
sublibrary of the Comm Sources library
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• Binary Symmetric Channel block, from the Channels library

• Error Rate Calculation block, from the Comm Sinks library

• Display block, from the Simulink Sinks library

Setting Parameters in the Channel Noise Model
To set block parameters in the channel noise model, do the following:

1 Double-click the Binary Symmetric Channel block and make the following
changes to the default parameters in the block’s dialog:

• Set Error probability to 0.01.

• Clear the Output error vector check box. This removes the block’s
lower output port, which is not needed for this model.

2 Double-click the Error Rate Calculation block and make the following
changes to the default parameters in the block’s dialog:

• Set Output data to Port to create an output port for the block.

• Select Stop simulation.
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Selecting Stop simulation causes the simulation to stop after the target
number of errors occurs or the maximum number of symbols is reached.

Initial Seeds
The Bernoulli Binary Generator block and the Binary Symmetric Channel
block both use a random number generator to generate random sequences
of bits. In both blocks, the Initial seed parameter initializes the random
sequence. The initial seeds in the two blocks should have different values
to ensure that the source signal and the channel noise are statistically
independent. In general, initial seeds should have different values in all
blocks that have an Initial seed parameter.

Connecting the Blocks
Next, connect the blocks as shown in the following figure. Make sure to
connect the arrow from the Binary Symmetric Channel block to the input port
labeled Rx on the Error Rate Calculation block. To learn how to do this, see
“Connecting Blocks” on page 2-16.

The next section explains how to draw the upper branch line in the model.

Drawing a Branch Line
The upper line leading from the Bernoulli Binary Generator block to the Error
Rate Calculation block, shown in the following figure, is called a branch line.
Branch lines carry the same signal to more than one block.

To draw the branch line, follow these steps:

1 Right-click the line between the Bernoulli Random Generator block and the
Binary Symmetric Channel block.
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2 While holding down the right mouse button, move the mouse pointer to the
input port labeled Tx on the Error Rate Calculation block.

3 Release the mouse button. The end of the branch line should connect to the
input port of the Error Rate Calculation block.

4 Click the horizontal section of the branch line and drag it upward until the
line is above the Binary Symmetric Channel block.

The model should now appear as in the following figure.

Running the Channel Noise Model
To run the model, select Simulation > Start. After a few seconds, the model
stops automatically.

To see all three boxes in the Display block, you must enlarge the block slightly,
as follows:

1 Select the Display block and move the mouse pointer to one of the lower
corners of the block, so that a diagonal arrow appears on the corner, as
shown.

2 Drag the corner of the block down with the mouse until three windows
appear, as shown.
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The Display block displays the following information:

• Bit error rate

• Number of errors

• Total number of bits that are transmitted

The exact values that appear will vary, depending on the Initial seed
parameters in the Bernoulli Binary Generator block and the Binary
Symmetric Channel block.

Because the Target number of errors in the dialog box for the Error Rate
Calculation block is set to 100, the simulation stops when 100 errors have
been detected.

To save the model, select File > Save, type a name for the model, such as
channelnoise, in the File name field, and click Save.
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Reducing the Error Rate Using a Hamming Code
This section describes how to reduce the error rate in the model shown in the
figure Channel Noise Model on page 2-24 by adding an error-correcting code.
The following figure shows an example that uses a Hamming code.

Hamming Code Model

The topics in this section are as follows:

• “Building the Hamming Code Model” on page 2-30

• “Using the Hamming Encoder and Decoder Blocks” on page 2-32

• “Setting Parameters in the Hamming Code Model” on page 2-32

• “Labeling the Display Block” on page 2-33

• “Running the Hamming Code Model” on page 2-33

• “Displaying Frame Sizes” on page 2-34

• “Adding a Scope to the Model” on page 2-34

• “Setting Parameters in the Expanded Model” on page 2-35

• “Observing Channel Errors with the Scope” on page 2-37

You are encouraged to build the model for yourself. Alternatively, to open a
completed version of the model, type hammingdoc at the MATLAB prompt.

Building the Hamming Code Model
You can build the Hamming code model by adding blocks to the model shown
in the figure Channel Noise Model on page 2-24. To do so, follow these steps:
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1 Type channeldoc at the MATLAB prompt to open the channel noise model.
Then save the model as my_hamming in the directory where you keep your
work files. See “Saving a Model” on page 2-22.

2 Drag the following two Communications Blockset blocks from the Simulink
Library Browser into the model window:

• Hamming Encoder block, from the Block sublibrary of the Error
Detection and Correction library

• Hamming Decoder block, from the Block sublibrary of the Error
Detection and Correction library

3 Click the right border of the model and drag it to the right to widen the
model window.

4 Move the Binary Symmetric Channel block, the Error Rate Calculation
block, and the Display block to the right by clicking and dragging. This
creates more space between the Binary Symmetric Channel block and the
blocks next to it. The model should now look like the following figure.

5 Click the Hamming Encoder block and drag it on top of the line between
the Bernoulli Binary Generator block and the Binary Symmetric Channel
block, to the right of the branch point, as shown in the following figure.
Then release the mouse button. The Hamming Encoder block should
automatically connect to the line from the Bernoulli Binary Generator
block to the Binary Symmetric Channel block.
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6 Click the Hamming Decoder block and drag it on top of the line between
the Binary Symmetric Channel block and the Error Rate Calculation block.

Using the Hamming Encoder and Decoder Blocks
The Hamming Encoder block encodes the data before it is sent through the
channel. The default code is the [7,4] Hamming code, which encodes message
words of length 4 into codewords of length 7. As a result, the block converts
frames of size 4 into frames of size 7. The code can correct one error in each
transmitted codeword.

For an [n,k] code, the input to the Hamming Encoder block must consist of
vectors of size k. In this example, k = 4.

The Hamming Decoder block decodes the data after it is sent through the
channel. If at most one error is created in a codeword by the channel, the
block decodes the word correctly. However, if more than one error occurs, the
Hamming Decoder block might decode incorrectly.

To learn more about the block coding features of the Communications Blockset,
see “Block Coding” in the online documentation for the Communications
Blockset.

Setting Parameters in the Hamming Code Model
Double-click the Bernoulli Binary Generator block and make the following
changes to the parameter settings in the block’s dialog box, as shown in the
following figure:

1 Select the box next to Frame-based outputs.

2 Set Samples per frame to 4. This converts the output of the block into
frames of size 4, in order to meet the input requirement of the Hamming
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Encoder Block. See “Frames and Frame-Based Processing” on page 2-22
for more information about frames.

Note Many Communications Blockset blocks, such as the Hamming
Encoder block, require their input to be a vector of a specific size. If you
connect a source block, such as the Bernoulli Binary Generator block, to
one of these blocks, select the box next to Frame-based outputs in the
dialog for the source, and set Samples per frame to the required value.

Labeling the Display Block
You can change the label that appears below a block to make it more
informative. For example, to change the label below the Display block to
“Error Rate Display,” first select the label with the mouse. This causes a box
to appear around the text. Enter the changes to the text in the box.

Running the Hamming Code Model
To run the model, select Simulation > Start. The model terminates after
100 errors occur. The error rate, displayed in the top window of the Display
block, is approximately .001. You get slightly different results if you change
the Initial seed parameters in the model or run a simulation for a different
length of time.

You expect an error rate of approximately .001 for the following reason: The
probability of two or more errors occurring in a codeword of length 7 is
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1 – (0.99)7 – 7(0.99)6(0.01) = 0.002

If the codewords with two or more errors are decoded randomly, you expect
about half the bits in the decoded message words to be incorrect. This
indicates that .001 is a reasonable value for the bit error rate.

To obtain a lower error rate for the same probability of error, try using a
Hamming code with larger parameters. To do this, change the parameters
Codeword length and Message length in the Hamming Encoder and
Decoder block dialog boxes. You also have to make the appropriate changes
to the parameters of the Bernoulli Binary Generator block and the Binary
Symmetric Channel block.

Displaying Frame Sizes
You can display the sizes of data frames in different parts of the model by
selecting Signal dimensions from the Port/signal displays submenu of the
Format menu at the top of the model window. This is shown in the following
figure. The line leading out of the Bernoulli Binary Generator block is labeled
[4x1], indicating that its output consists of column vectors of size 4. Because
the Hamming Encoder block uses a [7,4] code, it converts frames of size 4 into
frames of size 7, so its output is labeled [7x1].

Displaying Frame Sizes

Adding a Scope to the Model
To display the channel errors produced by the Binary Symmetric Channel
block, add a Scope block to the model. This is a good way to see whether your
model is functioning correctly. The example shown in the following figure
shows where to insert the Scope block into the model.
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To build this model from the one shown in the figure Hamming Code Model on
page 2-30, follow these steps:

1 Drag the following blocks from the Simulink Library Browser into the
model window:

• Relational Operator block, from the Simulink Logic and Bit Operations
library

• Scope block, from the Simulink Sinks library

• Two copies of the Unbuffer block, from the Buffers sublibrary of the
Signal Processing Blockset Signal Management library

2 Double-click the Binary Symmetric Channel block to open its dialog box,
and select Output error vector. This creates a second output port for the
block, which carries the error vector.

3 Double-click the Scope block and click the Parameters button on the
toolbar. Set Number of axes to 2 and click OK.

4 Connect the blocks as shown in the preceding figure. To learn how to do
this, see “Connecting Blocks” on page 2-16 and “Drawing a Branch Line”
on page 2-27.

Setting Parameters in the Expanded Model
Make the following changes to the parameters for the blocks you added to
the model.
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Error Rate Calculation Block
Double-click the Error Rate Calculation block and clear the box next to Stop
simulation in the block’s dialog box.

Scope Block
The Scope block displays the channel errors and uncorrected errors. To
configure the block,

1 Double-click the block to open the scope, if it is not already open.

2 Click the Parameters button on the toolbar.

3 Set Time range to 5000.

4 Click the Data history tab.

5 Type 30000 in the Limit data points to last field, and click OK.

The scope should now appear as shown.

To configure the axes, follow these steps:

1 Right-click the vertical axis at the left side of the upper scope.

2 In the context menu, select Axes properties.

3 In the Y-min field, type -1.
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4 In the Y-max field, type 2, and click OK.

5 Repeat the same steps for the vertical axis of the lower scope.

6 Widen the scope window until it is roughly three times as wide as it is high.
You can do this by clicking the right border of the window and dragging the
border to the right, while pressing the mouse button.

Relational Operator
Set Relational Operator to ~= in the block’s dialog box. The Relational
Operator block compares the transmitted signal, coming from the Bernoulli
Random Generator block, with the received signal, coming from the Hamming
Decoder block. The block outputs a 0 when the two signals agree and a 1
when they disagree.

Observing Channel Errors with the Scope
When you run the model, the Scope block displays the error data. At the end of
each 5000 time steps, the scope appears as shown in the following figure. The
scope then clears the displayed data and displays the next 5000 data points.

Scope with Model Running

The upper scope shows the channel errors generated by the Binary Symmetric
Channel block. The lower scope shows errors that are not corrected by
channel coding.

Click the Stop button on the toolbar at the top of the model window to stop
the scope.
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To zoom in on the scope so that you can see individual errors, first click the
middle magnifying glass button at the top left of the Scope window. Then click
one of the lines in the lower scope. This zooms in horizontally on the line.
Continue clicking the lines in the lower scope until the horizontal scale is fine
enough to detect individual errors. A typical example of what you might see
is shown in the figure below.

Zooming In on the Scope

The wider rectangular pulse in the middle of the upper scope represents two
1s. These two errors, which occur in a single codeword, are not corrected.
This accounts for the uncorrected errors in the lower scope. The narrower
rectangular pulse to the right of the upper scope represents a single error,
which is corrected.

When you are done observing the errors, select Simulation > Stop.

“Sending Signal and Error Data to the Workspace” on page 3-4 explains how
to send the error data to the MATLAB workspace for more detailed analysis.
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Modeling a Channel with Modulation
The Binary Symmetric Channel block, which simulates a channel with
noise, is useful for building models of channel coding. For other types of
applications, you might want to construct a more realistic model of a channel.
For example, you can add modulation and demodulation, and replace the
Binary Symmetric Channel block with an AWGN Channel block, which adds
white Gaussian noise to the channel. The following figure shows an example
that uses binary phase shift keying (BPSK).

BPSK Modulation Model

The topics in this section are as follows:

• “Building the BPSK Model” on page 2-39

• “Setting Parameters in the BPSK Model” on page 2-40

• “Running the BPSK Model” on page 2-41

You are encouraged to build the model for yourself. Alternatively, to open a
completed version of the model, type bpskdoc at the MATLAB prompt.

Building the BPSK Model
You can build the BPSK model from the one shown in the figure Channel
Noise Model on page 2-24. To build the model, follow these steps:

1 Enter channeldoc at the MATLAB prompt to open the channel noise
model, and then save the model as my_bpsk in the directory where you
keep your work files.

2 Delete the Binary Symmetric Channel block from the model by
right-clicking the block and selecting Clear.
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3 Move the following blocks from the Simulink Library Browser into the
model window, and insert them into the model as shown in the following
figure:

• BPSK Modulator Baseband block, from PM in the Digital Baseband
Modulation sublibrary of the Modulation library

• AWGN Channel block, from the Channels library

• BPSK Demodulator Baseband block, from PM in the Digital Baseband
Modulation sublibrary of the Modulation library

The model should now appear as in the figure below.

Binary Phase Shift Keying
The BPSK Modulator and Demodulator Baseband blocks implement binary
phase shift keying (BPSK) modulation. BPSK is a method for modulating a
binary signal onto a complex waveform by shifting the phase of the complex
signal. In digital baseband BPSK, the symbols 0 and 1 are modulated to the
complex numbers exp(jt) and -exp(jt), respectively, where t is a fixed angle. In
this example, t = 0, so these numbers are just 1 and -1.

You can set the value of t in the Phase offset parameter in the dialog
boxes for the BPSK Modulator Baseband block and the BPSK Demodulator
Baseband block. The default value is 0.

To learn more about the digital modulation features of the Communications
Blockset, see “Digital Modulation” in the online Communications Blockset
documentation.

Setting Parameters in the BPSK Model
To set block parameters in the BPSK model, do the following:
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1 Double-click the AWGN Channel block and set Es/No to 4.2.

2 Double-click the Error Rate Calculation block and make the following
changes to the default parameters in the block’s dialog:

• Set Output data to Port.

• Select the box next to Stop simulation.

Running the BPSK Model
When you run the model, the Display block shows an error rate of
approximately 0.01, the same as in the channel noise model. The BPSK model
uses the BPSK Modulator Baseband, the AWGN Channel, and the BPSK
Demodulator Baseband blocks to simulate a channel with noise. This provides
a more realistic model of a channel than using just the Binary Symmetric
Channel block. You can also model other types of channel noise using blocks
from the Communications Blockset Channels library.
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Reducing the Error Rate with a Cyclic Code
You can improve the error rate in the model shown in the figure BPSK
Modulation Model on page 2-39, for certain noise levels, by adding channel
coding. An example that uses a binary cyclic code is shown below.

This section covers these topics:

• “Building the Cyclic Code Model” on page 2-42

• “Running the Cyclic Code Model” on page 2-44

• “Verifying the Symbol Period” on page 2-44

• “Using a Probe Block to Determine Symbol Period” on page 2-45

Building the Cyclic Code Model
You can build the cyclic code model by adding blocks to the BPSK model
shown in the figure BPSK Modulation Model on page 2-39. To build the
model, follow these steps:

1 Open the BPSK model by entering bpskdoc at the MATLAB prompt. Save
the model as my_cyclic in the directory where you keep your work files.

2 Double-click the AWGN Channel block and set Es/No to 7. This value is
chosen for this example to illustrate the benefit of using a code. If Es/N0 is
much lower than the value chosen here, then the Es/N0 reduction caused
by the additional coded bits will be greater than the coding gain provided
by the code.

3 Run the simulation and note its error rate (for later comparison in
“Running the Cyclic Code Model” on page 2-44). The error rate appears in
the top entry of the Display block.
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4 To introduce cyclic coding, drag these Communications Blockset blocks
from the Simulink Library Browser into the model window:

• Binary Cyclic Encoder block, from the Block sublibrary of the Error
Detection and Correction library

• Binary Cyclic Decoder block, from the Block sublibrary of the Error
Detection and Correction library

5 Widen the model window and connect the blocks as below.

6 Double-click the Bernoulli Binary Generator block and change these
parameters:

• Select Frame-based outputs.

• Set Samples per frame to 21 to match the input requirement of the
Binary Cyclic Encoder block.

7 Double-click the Binary Cyclic Encoder block and change these parameters:

• Set Codeword length N to 31.

• Set Message length K to 21.

Make the same changes in the Binary Cyclic Decoder block.

8 Double-click the AWGN Channel block and change these parameters:

• Set Es/No to 7+10*log10(21/31). The second term in this sum accounts
for the difference in symbol period compared to the original BPSK model.

• Set Symbol period to 21/31. For more information on setting Symbol
period, see “Verifying the Symbol Period” on page 2-44.

With these parameter values, the AWGN channel block produces the same
amount of noise per symbol as in the BPSK model (without coding) in
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which Es/No is 7. The equivalence of the noise enables you to determine
how much the cyclic code improves the bit error rate.

9 Double-click the Error Rate Calculation block and change this parameter:

• Set Maximum number of symbols to 1e7. This extends the
simulation, producing a more reliable estimate for the error rate.

Binary Cyclic Encoder and Decoder
The Binary Cyclic Encoder block implements a binary cyclic code. In this
example, the block has the following parameter settings:

• Codeword length N = 31

• Message length K = 21

The code rate is given by

Code rate
Message length

Codeword length
=

This example uses a rate 21/31 code. The codeword length N must have the
form 2M - 1, where M is an integer greater than or equal to 3. The input to the
block must be a vector whose length is Message length.

The Binary Cyclic Decoder block decodes the demodulated signal. This block
must have the same parameter settings as the Binary Cyclic Encoder block.

Running the Cyclic Code Model
When you run the simulation, the bit error rate is less than one-tenth of the
error rate in the model that does not have channel coding.

Verifying the Symbol Period
When you compare the cyclic code model to the BPSK model, which does
not have channel coding, the ratio of energy per information symbol to noise
spectral density, Eb/N0, should be the same in both models. You can use the
Symbol period and Es/No parameters in the AWGN Channel block to adjust
the amount of channel noise so that Eb/N0 is the same as in the model without
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coding. Because the cyclic code has rate 21/31, set Symbol period to 21/31.
For a BPSK simulation with a rate K / N code, set Symbol period to K/N
because there are K information symbols for each N channel symbols.

Note that Es/No, the ratio of energy per channel symbol to noise spectral
density, is not the same as Eb/N0. To convert between the two, use the formula

E N E N K Nb s/ / log( / )0 0 10= −

where K / N is the ratio of information symbols to channel symbols. Changing
the Symbol period to K/N has the same effect as subtracting 10log(K / N)
from the Es/No parameter.

Using a Probe Block to Determine Symbol Period
If you are unsure how to set the Symbol period, you can find the correct
value using a Probe block. To do so, follow these steps:

1 Drag these blocks from the Simulink Library Browser into the cyclic code
model window:

• Probe block, from the Simulink Signal Attributes library

• Two copies of the Terminator block, from the Simulink Sinks library

2 Double-click the Probe block and change these parameters:

• Clear the boxes next to Probe complex signal and Probe signal
dimensions.

• Select the boxes next to Probe width and Probe sample time. The
block now has two output ports.

3 Connect the blocks as shown in the next figure.

4 Select Edit > Update diagram. Simulink updates the display on the
Probe block, as in the next figure.
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The number after W in the Probe block tells you the frame size, which in this
case is 31. The first number after Tf tells you the frame period, which is 21.
You can determine the symbol period using the following formula.

Symbol period
Frame period

Frame size
=

In this example, the symbol period is 21/31.
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Building a Frequency-Shift Keying Model
Frequency-shift keying (FSK) is a standard modulation technique in which a
digital signal is modulated onto a sinusoidal carrier whose frequency shifts
between different values. The Bell Telephone System first used this technique
in their Model 103 modem. The model shown in the following figure is an
example of the baseband representation of FSK.

FSK Model

The topics in this section are as follows:

• “Building the FSK Model” on page 2-48

• “Setting Parameters in the FSK Model” on page 2-49

• “Running the FSK Model” on page 2-50

• “Learning About Delays in the Model” on page 2-51

• “Finding the Delay in a Model” on page 2-51

• “Learning About Multirate Models” on page 2-52

• “Using Sample Time Colors to Check Sample Times” on page 2-52

To open a completed version of the model, type fskdoc at the MATLAB
prompt.
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Building the FSK Model
You can build the FSK model by adding blocks to the model shown in the figure
Channel Noise Model on page 2-24. To open the channel noise model, enter
channeldoc at the MATLAB prompt. Then save the model as my_fsk in the
directory where you keep your work files. See “Saving a Model” on page 2-22.

You need to add the following blocks to the model:

M-FSK Modulator and Demodulator Baseband
The M-FSK Modulator Baseband block, from FM in the Digital Baseband
sublibrary of the Modulation library, modulates the binary signal using a
baseband representation of FSK modulation.

The M-FSK Demodulator Baseband block, from FM in the Digital Baseband
sublibrary of the Modulation library, demodulates the baseband signal.

AWGN Channel
The AWGN Channel block, from the Channels library, models a channel using
additive white Gaussian noise. In this model, AWGN is more suitable than a
binary symmetric channel.

Relational Operator
The Relational Operator block, from the Simulink Logic and Bit Operations
library, compares the transmitted signal, from the Bernoulli Binary Generator
block, with the received signal, from the M-FSK Demodulator Baseband block.
The block outputs a 0 when the two signals agree, and a 1 when they differ.

Scope
The Scope block, from the Simulink Sinks library, displays the transmitted
signal, the received signal, and the output of the Relational Operator block.
To create three input ports for the block, follow these steps:

1 Double-click the block to open the scope.

2 Click the Parameters button on the toolbar.

3 Set Number of axes to 3.
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4 Set Time range to 1 and click OK.

To set the limits on the vertical axes,

1 Right-click the vertical axis at the left side of the upper scope.

2 In the context menu, select Axes properties.

3 In the Y-min field, type -1.

4 In the Y-max field, type 2, and click OK.

Repeat these steps for the middle and lower vertical axes.

Delay
The Delay block, from the Signal Processing Blockset Signal Operations
library, delays the transmitted signal so that it can be accurately compared
with the received signal. Its purpose is explained further in “Learning About
Delays in the Model” on page 2-51.

Drag these blocks into the model window and connect them as shown in the
figure FSK Model on page 2-47. Remove the Binary Symmetric Channel block
because it is no longer needed. The next section explains how to set the
parameters for these blocks.

Setting Parameters in the FSK Model
Make the following changes to the default parameter settings in the dialog
boxes for the blocks:

1 Double-click the Bernoulli Binary Generator block and make the following
changes to the default parameters in the block’s dialog box:

• Set Probability of a zero to 0.5.

• Set Sample time to 1/1200.

2 Double-click the M-FSK Modulator Baseband block and make the following
changes to the default parameters in the block’s dialog box:
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• Set M-ary number to 2. This specifies the number of frequencies in
the modulated signal.

• Set Frequency separation to 1000. This specifies the separation
between the two frequencies of the modulated signal.

• Set Samples per symbol to 5. This causes the block to oversample
the incoming signal. Oversampling increases the sampling rate by a
factor of 5.

3 Double-click the M-FSK Demodulator Baseband block and make the same
changes to the block’s default parameters as for the M-FSK Modulator
Baseband block.

4 Double-click the AWGN Channel block and set Symbol period to 1/1200.

5 Double-click the Error Rate Calculation block and make the following
changes to the default parameters in the block’s dialog box:

• Set Receive delay to 1.

• Set Output data to Port.

Running the FSK Model
Set the Stop time parameter to 15 and run the model.

Displaying the Errors in the Scope
Double-click the Scope block to open the scope.

The top window displays the transmitted signal. The middle window displays
the received signal. The bottom window displays a 0 where the two signals
agree and a 1 where they differ.
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Learning About Delays in the Model
Some blocks cause a signal to be delayed as it passes through a model,
because of the way they process data. For example, there is a delay of one
symbol period between the input signal to the M-FSK Modulator Baseband
block and the output signal from the M-FSK Demodulator Baseband block. As
a result, there is a delay of 1 between the transmitted and received signals
in the model. “Finding the Delay in a Model” on page 2-51 shows how to
find the value of this delay.

To compare these two signals and calculate the bit error rate correctly, you
need to delay the transmitted signal by 1 to synchronize it with the received
signal. This is why you set the Receive delay to 1 in the dialog box for the
Error Rate Calculation block, and left the Delay at its default value of 1 in
the Delay block.

Note If the Error Rate Calculation block in a model gives an error rate close
to .5 for a random binary signal, you might not have taken into account delays
in the model. The block is probably comparing two unsynchronized signals.

Several blocks in the Communications Blockset Modulation library produce
delays. A list of these is given in “Delays in Digital Modulation” in the online
Communications Blockset documentation. The Viterbi Decoder block, from
the Convolutional sublibrary of the Error Detection and Correction library,
also produces a delay equal to its Traceback depth parameter; see the
section “Viterbi Decoder” on page 2-56.

Finding the Delay in a Model
To find the delay between the transmitted and received signals in a model,
you can use a Find Delay block. To do so, insert the following blocks into
the FSK model:

• Find Delay, from the Utility Blocks library

• Display, from the Simulink Sinks library

Connect the blocks as shown at the top right of the following figure.
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When you run the simulation, the Display block labeled Display shows
that the delay is 1. You can use this information to set the Receive delay
parameter in the Error Rate Calculation block and the Delay parameter in
the Delay block.

Learning About Multirate Models
The model shown in the figure FSK Model on page 2-47 differs from the
earlier models in that it contains signals with different sample times. The
Bernoulli Binary Generator block has a sample time of 1/1200. The M-FSK
Modulator Baseband block receives this signal and upsamples it at a rate of
five samples per symbol. As a result, the sample time of the block’s output
signal is 1/6000. A model that contains signals with different sample times
is called a multirate model.

The multiple sample times present in this model do not affect the bit error
rate of a simulation. But be aware that in other models, sample times can
affect the results of a simulation. This is usually the case when different
signals are combined. See “Setting Sample Times and Samples per Frame”
on page 3-17 for an example of this.

Using Sample Time Colors to Check Sample Times
You can easily check whether there are different sample times in a model by
selecting Sample time colors from the Port/signal displays submenu
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of the Format menu. Then select Update diagram from the Edit menu.
When you do this, blocks and lines in the model are colored according to their
sample times.

Red blocks and lines indicate the fastest sample time in the model. Green
indicates the second fastest sample time. Yellow blocks contain signals with
different sample times. If all sample times in the model are the same, all
blocks and lines are colored red. For more information on sample time colors,
see the Simulink documentation.

For frame-based signals, the colors correspond to the frame periods of the
signals rather than sample times.

If you need to determine the actual sample time of a signal, you can use
a Probe block as described in “Using a Probe Block to Determine Symbol
Period” on page 2-45.
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Building a Convolutional Code Model
The following model simulates the use of convolutional coding to send a signal
through a channel with noise.

Convolutional Code Model

The topics in this section are as follows:

• “Building the Convolutional Code Model” on page 2-54

• “Understanding the Blocks in the Model” on page 2-55

• “Setting Parameters in the Convolutional Code Model” on page 2-56

• “Running the Convolutional Code Model” on page 2-57

To open a completed version of the model, enter convdoc at the MATLAB
prompt.

Building the Convolutional Code Model
You can build the convolutional code model by adding blocks to the model
shown in the figure Channel Noise Model on page 2-24.

To build the model, follow these steps:

1 Enter channeldoc at the MATLAB Help browser to open the channel noise
model. Then save the model as my_conv in the directory where you keep
your work files.

2 Delete the Binary Symmetric Channel block.

3 Drag the following blocks from the Simulink Library Browser into the
model window, and connect them as shown in the figure Convolutional
Code Model on page 2-54:
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• Convolutional Encoder, from the Convolutional sublibrary of the Error
Detection and Correction library

• BPSK Modulator Baseband, from PM in the Digital Baseband
Modulation sublibrary of the Modulation library

• Complex to Real-Imag, from the Simulink Math Operations library

• Viterbi Decoder, from the Convolutional sublibrary of the Error Detection
and Correction library

Understanding the Blocks in the Model
The model contains the following blocks:

Convolutional Encoder
The Convolutional Encoder block encodes the signal from the Bernoulli Binary
Generator. The example uses the industry standard rate 1/2 convolutional
code, with constraint length 7, defined by the following diagram.
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Convolutional Encoder Schematic Block Diagram

The encoder structure is described by a pair of binary numbers, having the
same length as the code’s constraint length, that specify the connections from
the delay cells to modulo-2 addition nodes. The binary number for the upper
addition node is 1111001. A 1 indicates that the bit in the corresponding
delay cell (reading from left to right) is sent to the addition node, and a 0
indicates that the bit is not sent. The binary number for the lower addition
node is 1011011. Converting these two binary numbers to octal gives the
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pair [171,133]. You can enter this pair into the block’s dialog box by typing
poly2trellis(7, [171 133]) in the field for Trellis Structure.

To learn more about the convolutional coding features of the Communications
Blockset, see “Convolutional Coding” in the online Communications Blockset
documentation.

Complex to Real-Imag
The Complex to Real-Imag block, labeled Re(u), receives the complex signal
and outputs its real part. Because the output BPSK Modulator Baseband
block has zero complex part, all of the signal is carried by the real part. You
can set this option by selecting Real in the Output parameter field in the
block’s dialog box. It is not necessary to demodulate the signal, because the
Viterbi Decoder block can accept unquantized inputs.

Viterbi Decoder
The Viterbi Decoder block decodes the signal using the Viterbi algorithm. The
Decision Type parameter is set to Unquantized so that the block can accept
real numbers from the Complex to Real-Imag block. The Traceback depth
parameter, which is set to 96, is the number of branches in the trellis that
the block uses to construct each traceback path. This produces a delay of 96
between the input and output of the block. For more information on delays,
see “Finding the Delay in a Model” on page 2-51.

For an example of a convolutional coding model that uses soft-decision
decoding, see “Example: Soft-Decision Decoding” in the online
Communications Blockset documentation.

Setting Parameters in the Convolutional Code Model
To set parameters in the convolutional code model, do the following:

1 Double-click the Bernoulli Binary Generator block and select the box next
to Frame-based outputs in the block’s dialog box.

2 Double-click the AWGN Channel block and make the following changes to
the default parameters in the block’s dialog box:

• Set Es/No to -1.
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• Set Symbol period to 1/2. Because the code rate is 1/2, this setting
causes the block to produce the same amount of noise per channel symbol
as it would without channel coding. For more information, see “Verifying
the Symbol Period” on page 2-44.

3 Double-click the Error Rate Calculation block and make the following
changes to the default parameters in the block’s dialog box:

• Set Receive delay to 96. The Viterbi Decoder block creates a delay of
96, due to its Traceback depth setting.

• Select the box next to Stop simulation.

• Set Target number of errors to 100.

Running the Convolutional Code Model
When you run the model, you observe an error rate of approximately .003.
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3

Using the Communications
Blockset with MATLAB

This chapter describes how to use MATLAB to extend the capabilities of the
Communications Blockset. The chapter explains how to run simulations from
the command line, and how to run multiple simulations. It also explains how
to transfer data between a model and the MATLAB workspace.

Sending Data to the MATLAB
Workspace (p. 3-2)

Sending the simulation results to
the MATLAB workspace and using
MATLAB to analyze the data

Running Simulations from the
Command Line (p. 3-7)

Running models from the
MATLAB command line, running
multiple simulations with varying
parameters, and plotting the results
of multiple simulations

Importing Data from the MATLAB
Workspace (p. 3-14)

Importing data from the workspace
into a model

Learning More (p. 3-19) Other resources for learning about
the Communications Blockset
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Sending Data to the MATLAB Workspace
This section explains how to send data from a Simulink model to the MATLAB
workspace so you can analyze the results of simulations in greater detail.

The topics in this section are as follows:

• “Using a Signal To Workspace Block” on page 3-2

• “Configuring the Signal To Workspace Block” on page 3-3

• “Viewing the Error Rate Data in the Workspace” on page 3-3

• “Sending Signal and Error Data to the Workspace” on page 3-4

• “Viewing the Signal and Error Data in the Workspace” on page 3-5

• “Analyzing Signal and Error Data” on page 3-5

Using a Signal To Workspace Block
You can use a Signal To Workspace block, from the Signal Processing Sinks
library of the Signal Processing Blockset, to send data to the MATLAB
workspace as a vector. For example, you can send the error rate data from
the Hamming code model, described in the section “Reducing the Error Rate
Using a Hamming Code” on page 2-30. To insert a Signal to Workspace block
into the model, follow these steps:

1 Type hammingdoc at the MATLAB Help browser to open the model.

2 Drag a Signal To Workspace block, from the Signal Processing Sinks library,
into the model window and connect it as shown in the following figure.

Hamming Code Model with a Signal To Workspace Block
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Configuring the Signal To Workspace Block
To configure the Signal to Workspace block, follow these steps:

1 Double-click the block to display its dialog box.

2 Type hammcode_BER in the Variable name field.

3 Type 1 in the Limit data points to last field. This limits the output vector
to the values at the final time step of the simulation.

4 Click OK.

When you run a simulation, the model sends the output of the Error Rate
Calculation block to the workspace as a vector of size 3, called hamming_BER.
The entries of this vector are the same as those shown by the Error Rate
Display block.

Viewing the Error Rate Data in the Workspace
After running a simulation, you can view the output of the Signal to
Workspace block by typing the following commands at the MATLAB prompt:

format short e
hammcode_BER

The vector output is the following:

hammcode_BER =
5.4066e-003 1.0000e+002 1.8496e+004

The command format short e displays the entries of the vector in
exponential form. The entries are as follows:

• The first entry is the error rate.

• The second entry is the total number of errors.

• The third entry is the total number of comparisons made.
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Sending Signal and Error Data to the Workspace
To analyze the error-correction performance of the Hamming code, send the
transmitted signal, the received signal, and the error vectors, created by the
Binary Symmetric Channel block, to the workspace. An example of this is
shown in the following figure.

Sending Signal and Error Data to the Workspace

You can build this model from the one shown in the figure Hamming Code
Model on page 2-30. To build the model, follow these steps:

1 Type hammingdoc to open the model.

2 Double-click the Binary Symmetric Channel block to open its dialog box,
and select Output error vector. This creates an output port for the
error data.

3 Drag three Signal To Workspace blocks, from the Signal Processing Sinks
library, into the model window and connect them as shown in the preceding
figure.

4 Double-click the left Signal To Workspace block.

• Type Tx in the Variable name field in the block’s dialog box. The block
sends the transmitted signal to the workspace as an array called Tx.

• In the Frames field, select Log frames separately (3-D array). This
preserves each frame as a separate column of the array Tx.

• Click OK.

5 Double-click the middle Signal To Workspace block:
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• Type errors in the Variable name field.

• In the Frames field, select Log frames separately (3-D array).

• Click OK.

6 Double-click the right Signal To Workspace block:

• Type Rx in the Variable name field.

• In the Frames field, select Log frames separately (3-D array).

• Click OK.

Viewing the Signal and Error Data in the Workspace
After running a simulation, you can display individual frames of data. For
example, to display the tenth frame of Tx, at the MATLAB prompt type

Tx(:,:,10)

This returns a column vector of length 4, corresponding to the length of a
message word. Usually, you should not type Tx by itself, because this displays
the entire transmitted signal, which is very large.

To display the corresponding frame of errors, type

errors(:,:,10)

This returns a column vector of length 7, corresponding to the length of
a codeword.

To display frames 1 through 5 of the transmitted signal, type

Tx(:,:,1:5)

Analyzing Signal and Error Data
You can use MATLAB to analyze the data from a simulation. For example, to
identify the differences between the transmitted and received signals, type

diffs = Tx~=Rx;
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The vector diffs is the XOR of the vectors Tx and Rx. A 1 in diffs indicates
that Tx and Rx differ at that position.

You can determine the indices of frames corresponding to message words that
are incorrectly decoded with the following MATLAB command:

error_indices = find(diffs);

A 1 in the vector not_equal indicates that there is at least one difference
between the corresponding frame of Tx and Rx. The vector error_indices
records the indices where Tx and Rx differ. To view the first incorrectly
decoded word, type

Tx(:,:,error_indices(1))

To view the corresponding frame of errors, type

errors(:,:,error_indices(1))

Analyze this data to determine the error patterns that lead to incorrect
decoding.
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Running Simulations from the Command Line
This section describes how to run simulations from the command line using
the sim command. This is especially useful for running multiple simulations
on a model, as described in the next section.

The topics in this section are as follows:

• “Running a Single Simulation” on page 3-7

• “Running Multiple Simulations” on page 3-8

• “Plotting the Results of Multiple Simulations” on page 3-10

• “Running Multiple Simulations Using BERTool” on page 3-10

Running a Single Simulation
As an example, to run the phase noise model, described in “Running a
Simulink Model” on page 2-3, from the command line, enter

sim('phasenoise_sim')

in the MATLAB Command Window. This runs the model in the background
without opening the model window. While the simulation is running, the
MATLAB prompt is unavailable and you cannot enter another MATLAB
command.

After the simulation stops, the prompt reappears. You can then view the
results of the simulation by typing phasenoise_sim to open the model.

It is not necessary to open the model window when running a simulation from
the command line. Usually you want to send the results of the simulation to
the MATLAB workspace, for example, if you are running multiple simulations
on a single model.

You can also specify simulation parameters from the command line. For
example, the command

sim('phasenoise_sim', 1000);
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runs the model with a Stop time of 1000. This overrides the Stop time
setting in the Configuration Parameters dialog box. For more information on
running simulations, see the Simulink documentation.

Running Multiple Simulations
You can run multiple simulations, with different parameters, from the
command line using a MATLAB script. This section describes how to run the
phase noise model with varying amounts of channel noise.

Preparing the Model

1 Type phasenoise_sim to open the model.

2 Drag a Signal To Workspace block, from the Signal Processing Sinks library,
into the model window and connect it as shown in the following figure.

Phase Noise Model with a Signal To Workspace Block

3 Double-click the Signal To Workspace block and make these changes in
the block’s dialog box:

• Set Variable name to phase_err.

• Set Limit data points to last to 1.

4 Select Simulation > Configuration parameters and set Stop time to
inf.

5 Enter the following commands in the MATLAB Command Window. This
creates variables for the simulation’s stopping criteria, as well as a vector
of Eb/N0 values.

maxNumErrs = 200;
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maxNumBits = 10^5;
EbNoVec = 20:0.5:23;

6 Double-click the AWGN Channel block and set Es/No to EbNo+10*log10(8)
in the block’s dialog box. The variable EbNo represents the bit energy to
noise ratio. The term 10*log10(8) converts EbNo to Es/No, which is the
symbol energy to noise ratio. The 8 appears because there are eight bits
per channel symbol in 256-QAM.

7 Double-click the Error Rate Calculation block and make the following
changes in the block’s dialog box:

• Select Stop simulation.

• Set Target number of errors to maxNumErrs.

• Set Maximum number of symbols to maxNumBits.

8 Save the model in your working directory under a different file name, such
as my_phasenoise_sim.

Running the Simulation Multiple Times
Now that the model and variables are set up, you can run multiple
simulations, each with a different Es/No parameter. The following script runs
the simulations in a loop and stores the results in a matrix called SER_Vec.
The simulations might take several minutes to run.

SER_Vec=[];
for n = 1:length(EbNoVec);
EbNo = EbNoVec(n);
sim('my_phasenoise_sim');
SER_Vec(n,:) = phase_err;

end;

When the simulations have ended and the prompt reappears, enter the
following at the MATLAB prompt:

format short e
SER_Vec
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This displays the results in a matrix. Each row is the output of the Error Rate
Calculation block for a single simulation. The first column, which gives the
error rates for each simulation, decreases, because the noise level decreases
as EbNo increases. The last column gives the number of symbols processed in
each simulation.

Plotting the Results of Multiple Simulations
Plot the symbol error rates by entering the following commands.

semilogy(EbNoVec,SER_Vec(:,1),'*');
xlabel('Eb/No (dB)');ylabel('SER');
title('Phase Noise Performance of 256-QAM');
legend('Phase noise level: -66 dBc/Hz');

Running Multiple Simulations Using BERTool
The BERTool graphical user interface in the Communications Toolbox can
run multiple Simulink simulations and create a BER plot. This section
describes how to use BERTool with a modified phasenoise_sim model. For
more general instructions on using BERTool, see the BERTool section of the
Communications Toolbox documentation.
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To create a BER plot for the phase noise model using BERTool, follow these
steps:

1 Follow the procedure in “Preparing the Model” on page 3-8, if you have not
already done so. EbNo, maxNumErrs, and maxNumBits are special variable
names that BERTool recognizes.

2 Drag two Integer to Bit Converter blocks from the Utility Blocks library
into the model. Insert them before the Error Rate Calculation block, as
shown below. This causes the Error Rate Calculation block to compute a bit
error rate instead of a symbol error rate. BERTool is designed to compute
bit error rates.

3 Double-click each of the Integer to Bit Converter blocks and set Number
of bits per integer to 8 in the dialog boxes.

4 Save the model in your working directory as my_phasenoise_sim_ber.mdl.

5 Open the BERTool GUI by entering bertool in the MATLAB Command
Window.

6 Click the Monte Carlo tab.

7 Make the following changes in the GUI:

• Set Eb/No range to EbNoVec.

• Set Simulation M-file or model to my_phasenoise_sim_ber.mdl.

• Set BER variable name to phase_err.

• Set Number of errors to 200.

• Set Number of bits to 10^5.
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8 Click Run.

BERTool runs the simulation multiple times, gathers bit error rate results,
and produces a plot like the one below. (Although the shape resembles the
plot shown in “Plotting the Results of Multiple Simulations” on page 3-10, the
plot there shows symbol error rates while the plot here shows bit error rates.)
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Importing Data from the MATLAB Workspace
This section explains how to import data into a model directly from the
MATLAB workspace using the Signal From Workspace block, from the Signal
Processing Sources library. This enables you to run simulations on data that
you create in the workspace or import from outside MATLAB. You can also
create specific error patterns, such as burst errors, and import them into a
model to test error correction codes.

The topics of this section are as follows:

• “Simulating a Signal by Importing Data” on page 3-14

• “Simulating Noise with Imported Data” on page 3-15

• “Simulating Noise with Specified Error Patterns” on page 3-16

• “Setting Sample Times and Samples per Frame” on page 3-17

Simulating a Signal by Importing Data
To import a signal that you create in the workspace, you can use a Signal From
Workspace block as a source. An example is the model shown in the following
figure. This model is the same as the one shown in the figure Channel Noise
Model on page 2-24, except that the Bernoulli Binary Generator block has
been replaced with a Signal From Workspace block.

Importing a Signal from the Workspace

To build this model, follow these steps:

1 Enter channeldoc at the MATLAB prompt to open the channel noise
model. Then save it under a different name in the directory where you
keep your work files.

2 Replace the Bernoulli Binary Generator block with a Signal From
Workspace block, from the Signal Processing Sources library.
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3 In the Signal from Workspace block’s dialog, change the Signal parameter
to data (or another variable name).

Before using the model, define the vector data in the MATLAB workspace.
For example, type data=randint(1,10^4); at the MATLAB prompt. This
defines data as a random binary vector of length 104.

Next, select Simulation > Configuration parameters and set the Stop
time parameter to length(data). When you run a simulation, the model
imports the random vector data into the model.

Change the vector data in the MATLAB workspace to simulate a less random
signal, or import a signal from outside MATLAB.

Simulating Noise with Imported Data
You can also use the Signal From Workspace block to simulate channel noise
with specific error patterns, in order to test the performance of an error
correcting code. An example of this is shown in the following figure.

Using Data from the Workspace to Simulate Errors

This example is similar to the model shown in the figure Hamming Code
Model on page 2-30, but instead of using the Binary Symmetric Channel block
to simulate noise, the model imports error data from the workspace.

To build this model, follow these steps:

1 Type hammingdoc at the MATLAB prompt to open the Hamming code
model. Then save the model under a different name in the directory where
you store your work files.
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2 Delete the Binary Symmetric Channel block from the model.

3 Drag the following blocks into the model window:

• A Signal From Workspace block, from the Signal Processing Sources
library

• A Logical Operator block, from the Simulink Math Operations library

4 Connect these blocks as shown in the preceding figure.

5 Select Simulation > Configuration parameters to open the
Configuration Parameters dialog box.

6 Type length(errors) in the Stop time field and click OK.

7 Double-click the Signal From Workspace block and make the following
changes to the default parameters in the block’s dialog box:

• Set Signal to errors.

• Set Sample time to 4/7.

• Set Samples per frame to 7, to match the frame size of the signal
coming out of the Hamming Encoder block.

8 Double-click the Logical Operator block and set Operator to XOR in the
block’s dialog box.

Simulating Noise with Specified Error Patterns
To use the model in the figure Using Data from the Workspace to Simulate
Errors on page 3-15, you must first create a binary vector called errors in the
workspace to represent errors in the channel. A 1 in the vector represents
an error in the channel, while a 0 represents no error. When you run a
simulation, the Logical Operator block performs the XOR operation on the
vector errors and the signal.

For example, to create a vector of length 7x104 that contains exactly one 1
in each sequence of entries from 7n + 1 to 7(n + 1), enter the following at
the MATLAB prompt:

errors=[];
for n=1:10^4
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p=randperm(7);
v=[1 0 0 0 0 0 0];
errors=[errors v(p)];

end

The function randperm generates a random permutation of the numbers 1
through 7. The vector v(p) applies the permutation to the entries of the vector
v, which has exactly one entry that is 1. The result is that the vector errors
contains exactly one entry that is 1 in each sequence from 7n + 1 to 7(n+1).

Running a Simulation with Imported Error Data
When you run a simulation, the bit error rate is zero because the Hamming
code can correct one error in each codeword.

To test the code with an error vector that creates two errors in each codeword,
change the vector v to v=[1 1 0 0 0 0 0] in the preceding code.

Setting Sample Times and Samples per Frame
It is important to set the Sample time and Samples per frame parameters
correctly in the Signal From Workspace block, so that the block has the same
frame size and frame period as the Hamming Encoder block. This ensures
that errors coming from the Signal From Workspace block are synchronized
with channel symbols coming from the Hamming Encoder block. To determine
the correct sample time, use the following relationship:

Sample time
Frame period

Samples per frame
=

The frame size of the signal coming from the Hamming Encoder block is 7.
You set the frame size by the Codeword length parameter in the block’s
dialog box. So you should set the Samples per frame parameter in the
Signal From Workspace block to 7.

The frame period of the Hamming Encoder block is 4, because the Bernoulli
Binary Generator block has a Sample time of 1 and a Samples per frame
of 4. So set the Sample time parameter in the Signal From Workspace block
to 4/7 so that the frame period of the block is 4.
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If you are not sure what the frame sizes and frame periods of signals in the
model are, you can display them using a Probe block, as described in “Using a
Probe Block to Determine Symbol Period” on page 2-45. To do this, attach two
Probe blocks, one to the line leading out of the Hamming Encoder block and
one to the line leading out of the Signal From Workspace block. In the dialog
boxes for both Probe blocks, clear the check boxes next to Probe complex
signal and Probe signal dimensions. Next, attach Terminator blocks to
the output ports of the Probe blocks. Then select Update diagram from the
Edit menu. The model should appear as in the following figure.

Hamming Code Model with Probe Blocks

Both Probe blocks should display a frame size of 7 and a frame period of 4.

A quick way to check whether the frame periods of two signals are the same
is to select Sample time colors from the Port/signal displays submenu
of the Format menu. See “Using Sample Time Colors to Check Sample
Times” on page 2-52.
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Learning More
You can learn more about the Communications Blockset from the following
sources.

Online Help
To find online documentation, select Full Product Family Help from the
Help menu in the MATLAB desktop. This launches the Help browser. For
a more detailed explanation of any of the topics covered in this book, see
the documentation listed under Communications Blockset in the left pane
of the Help browser.

Besides this book, Getting Started with the Communications Blockset, the
online documentation contains the following topics:

• “Using the Libraries” describes each of the core libraries of the blockset.

• “Modeling Communication Systems” illustrates techniques for modeling a
full communication system.

• “Blocks — By Category” provides descriptions of the Communications
Blockset libraries and lists the blocks in them.

• “Blocks — Alphabetical List” provides a detailed description of the blocks
in the Communications Blockset in alphabetical order.

The Help Navigator, in the left pane of the Help browser, supports string
searches. You can specify strings and the online manuals that you want to
search. To begin a search, click the Search tab. To view the index for the
documentation, click the Index tab.

Demos
To see more Communications Blockset examples, type

demo

at the MATLAB prompt. This opens the MATLAB Demo window. Double-click
Blocksets and then select Communications to list the available demos.
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The MathWorks Online
To read the documentation for the Communications Blockset on the
MathWorks Web site, point your Web browser to

http://www.mathworks.com/access/helpdesk/help/helpdesk.shtml.
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List of Examples

Use this list to find examples in the documentation.



A List of Examples

Getting Started
“Running a Simulink Model” on page 2-3
“Building a Simple Model” on page 2-12
“Building a Channel Noise Model” on page 2-24
“Modeling a Channel with Modulation” on page 2-39
“Building a Frequency-Shift Keying Model” on page 2-47
“Building a Convolutional Code Model” on page 2-54
“Sending Data to the MATLAB Workspace” on page 3-2
“Running Multiple Simulations” on page 3-8
“Importing Data from the MATLAB Workspace” on page 3-14
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